ES2015 implementation of node EventEmitter

This is a clone of nodejs core EventEmitter module implemented with es2015 features (node v4.2+ required)