JavaScript Arrays : most of the time lodash/underscore.js is not needed

Recently I realized that I sometimes used lodash (or underscore.js) to do some basic processing over JavaScript Arrays on projects that don’t need to support old browsers. But since ECMAScript 5 support (IE9+), there is some methods available on the Array type that allow us to do these natively.